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ABSTRACT
Geographical  distribution  of  SAS  programming  teams  across  continents  and  oceans  impacts  the  access  to  study 
programs and data, so that it is only practical for local programmers to use direct GUI access to files, whereas remote 
programmers are forced to take copies of files onto their local systems to experience fast access.  With Enterprise Guide 
(EG), as all the executed code and data is still located on the designated server, but the viewing and editing of files is 
done on the local  PC,  network traffic  is  dramatically  reduced,  reducing the impact  of  remote working.   This  paper 
describes the steps needed to use EG, instead of batch SAS, to run server-based study programs from anywhere in the 
world.

ENVIRONMENT SETUP
When a SAS session is started on the server using Enterprise Guide (EG), the current folder used is always the user's 
home  folder  by  default,  e.g.  C:\WINDOWS\System32,    /home/user,  etc.   To  change  the  current  folder  to  a 
study-specific location the SAS code below can be used, for example:

%sysexec cd
      /filespace/product/indication/studynumber/analysis/final/tables/programs;
%sysexec setenv PWD
      /filespace/product/indication/studynumber/analysis/final/tables/programs;

Any automatic initialisation programs that calculate locations based on the current path will now be able to set all the 
study-specific macro variables and allocate the library and filename references.

If an autoexec.sas program is being used to set the study-specific macro variables and allocate the library and filename 
references, then it must be started here too.

%include 'autoexec.sas' / source2;

CHANGES TO  AUTOMATIC INITIALISATION PROGRAM
The only change required to the automatic initialisation program would to alter the way the program name is obtained.  In 
batch  SAS  sessions  the  program  name  forms  part  of  the  SYSPROCESSNAME  macro  variable,  e.g. "Program 
report.sas".  However, when submitted from EG, the SYSPROCESSNAME macro variable in the SAS session always 
contains "Object Server", with no program name at all.  Fortunately the label of the EG code node submitted is stored in 
the _EGTASKLABEL macro variable.  This label can be any string until the code is saved to disk, but, once saved, it is 
replaced by the name of the saved file.

Replace:

%let pgm = %scan(&sysprocessname, 2, %str( ));

with:

%if "&sysprocessname" = "Object Server"
  %then %let pgm = &_egtasklabel;
  %else %let pgm = %scan(&sysprocessname, 2, %str( ));

The code change in the automatic initialisation program above uses the _EGTASKLABEL macro variable, instead of the 
SYSPROCESSNAME macro variable, but only if the SYSPROCESSNAME macro variable contains "Object Server", so 
batch SAS sessions will not be impacted.
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LIMITATIONS OF ENTERPRISE GUIDE SOFTWARE
• As EG acts as an editor and batch scheduler for separate SAS systems, it cannot be used to run SAS applications 

that  have  their  own  GUI  interfaces  or  interactive  features,  e.g. SAS/AF,  SAS/EIS,  SAS/INSIGHT,  SAS/ASSIST, 
SAS/GIS,  SAS/Spectraview,  etc.   All  processes  should  be  considered  to  be  batch  jobs,  in  that  they  have  no 
interactive facilities.  However, the SAS code is actually running in a single SAS session on the selected SAS server, 
so, from the first code submission, WORK data sets, option settings and macro variables are retained until the end of 
the server session, or until they are manually deleted.

• The batch SAS processes can only return the following items back to EG:
SAS Log
SAS Output via ODS
SAS Graphs

• Although the EG user interface includes elements relating to Base SAS, SAS/STAT, SAS/GRAPH, SAS/ETS and 
SAS/QC, their applicability will depend on the SAS License installed on the SAS Server selected to run the code.

ACCESSING LOCAL SAS INSTALLATIONS
EG can be used as a point-and-click front-end to a locally-installed SAS system.  This requires client SAS software to be 
installed on the Windows system, including the local version of SAS Integration Technologies, which is supplied as part 
of Base SAS. The only SAS component that must be licensed is Base SAS.

Accessing the locally-installed SAS system may require it to be registered using the /REGSERVER option on SAS.EXE, 
if the installation has not been installed into the default location, or if several different versions have been installed on the 
same PC.  For automated installations, it is recommended that this registration is carried out even if the location is the 
default.

ACCESSING SERVER-BASED SAS INSTALLATIONS
A remote SAS server requires only Base SAS and SAS Integration Technologies to be installed and licensed to be 
accessed, although if SAS/STAT, SAS/GRAPH, SAS/ETS and SAS/QC are installed and licensed on the server, then 
they can have code generated for them by EG using standard Tasks.  Other components can also be used, but will 
require direct coding in a SAS Code node to be executed from EG.

The remote SAS server must be configured using the SAS Enterprise Guide Explorer, which can be accessed from EG 
by clicking Tools > SAS Enterprise Guide Explorer.  New servers can be added using the Server Wizard, which can be 
started from inside the SAS Enterprise Guide Explorer by clicking File > New > Server....  Each new server definition 
requires the following information: server name (user-defined, but must be unique), connection protocol (probably IOM), 
host address (either URL or IP address) and port number of the Object Spawner on the remote server.

WHY YOU CANNOT USE AUTOEXEC.SAS
EG communicates with the SAS System via a special interface component called SAS Integration Technologies.  As the 
requests for SAS functionality are normally small and frequent, starting a full SAS session each time would be wasteful, 
and probably too slow.  As a consequence SAS Integration Technologies only starts a minimal system which can be 
extended, if required, as the code is compiled.  This minimal system does not include any 'autoexec' processing, so any 
processing required to be carried out prior to each request must be initiated using the -INITSTMT option.  Therefore, the 
following option is the equivalent to the -AUTOEXEC option:

-INITSTMT '%INCLUDE "/home/user/autoexec.sas;"'

When using the Enterprise Guide Administrator, this -INITSTMT option is specified during the server setup screens by 
typing the following text in the SAS Server Startup Statements box on the Options tab:

%INCLUDE "/home/user/autoexec.sas";

As an  alternative,  the  -INITSTMT option  can  be  added  to  the  -sasCommand option  in  the  SAS Object  Spawner 
configuration file.

WHY DO PLATFORM-SPECIFIC SYSTEM COMMANDS FAIL?
The starting parameters on the SAS Object Spawners that start the SAS server sessions can have an impact on the 
permitted functionality of the SAS code submitted to run on the server.  Statements such as X, %SYSEXEC, SYSTASK 
and CALL SYSTEM, the SYSTEM function, and the FILENAME option PIPE will not work unless the -ALLOWXCMD or 
-NONOXCMD parameters are explicitly added to the Object Spawner configuration.  However, the use of these options 
should  only  be  permitted  with  great  caution,  as  other  platform-specific  operating  system  commands  can  also  be 
submitted from submitted SAS code, which could be dangerous when used by inexperienced or malicious users!

Note that even if you only run your SAS code on the Local Server, you will not be able to use statements such as X, 
%SYSEXEC, SYSTASK and CALL SYSTEM, the SYSTEM function, and the FILENAME option PIPE, unless you have 
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allowed operating system commands.  The Local Server parameters are stored in the Windows Registry and can be 
changed as follows (NB. after a backup of the Windows Registry has been taken, as any manual updates of the Registry 
can impact the operation of Windows!):

1. To back up the Windows Registry, click Start > All Programs > Accessories > System Tools > Backup. 
2. Select Back up files and settings, then click Next >.
3. Select Let me choose what to back up, then click Next >.
4. Expand My Computer, and select System State, then click Next >.
5. Click Browse to select a location for the backup, then click Save, then click Next >, and then click Finish to start 

the backup. 
6. To edit the Windows Registry, click Start > Run, then type REGEDIT, and click OK.
7. Select HKEY_CLASSES_ROOT with CLSID=440196D4, then click the LocalServer32 key.
8. Right-click Default, then click Modify.
9. Remove “-noxcmd”, which should be the last item in the list, then click OK.
10. Click View, then click Refresh.
11. Exit the Registry window.

CHANGING THE CURRENT DIRECTORY
When you  start  a  server  SAS session the current  directory  is  always  your  home directory  on the server  platform, 
e.g. C:\WINDOWS\System32 on Windows, or /home/user on Linux or UNIX.  To change this to a different location you 
will need to have the ability to run operating system commands (see 'Why Do Platform-specific System Commands Fail?' 
above).  Any of the 6 different techniques described are applicable:

1. X statement

On a Windows server:

OPTIONS NOXSYNC NOXWAIT;
X 'd:; cd d:\data\lib';

On a Linux or UNIX server:

OPTIONS NOXSYNC NOXWAIT;
X 'cd /data/lib';

2. %SYSEXEC statement

On a Windows server:

OPTIONS NOXSYNC NOXWAIT;
%SYSEXEC d:;
%SYSEXEC cd d:\data\lib;

On a Linux or UNIX server:

%SYSEXEC cd /data/lib;

3. SYSTASK statement

On a Windows server:

OPTIONS NOXSYNC NOXWAIT;
SYSTASK COMMAND 'd:; cd d:\data\lib';

On a Linux or UNIX server:

OPTIONS NOXSYNC NOXWAIT;
SYSTASK COMMAND 'cd /data/lib';

4. CALL SYSTEM statement

On a Windows server:

OPTIONS NOXSYNC NOXWAIT;
DATA _NULL_;
  CALL SYSTEM('d:; cd d:\data\lib');
RUN;

On a Linux or UNIX server:

OPTIONS NOXSYNC NOXWAIT;
DATA _NULL_;
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  CALL SYSTEM('cd /data/lib');
RUN;

5. SYSTEM function

On a Windows server:

OPTIONS NOXSYNC NOXWAIT;
DATA _NULL_;
  rc = SYSTEM('d:; cd d:\data\lib');
RUN;

On a Linux or UNIX server:

OPTIONS NOXSYNC NOXWAIT;
DATA _NULL_;
  rc = SYSTEM('cd /data/lib');
RUN;

6. FILENAME statement with the PIPE option

On a Windows server:

FILENAME cmd PIPE 'd:; cd d:\data\lib';
DATA _NULL_;
  INFILE cmd TRUNCOVER;
  INPUT;
  PUT _INFILE_;
RUN;

On a Linux or UNIX server:

FILENAME cmd PIPE 'cd /data/lib';
DATA _NULL_;
  INFILE cmd TRUNCOVER;
  INPUT;
  PUT _INFILE_;
RUN;

GENERATING SAS CODE USING EG TASKS
All the GUI tasks in EG generate SAS code which can be submitted automatically, but use of the Preview Code option 
gives the user an opportunity to copy the generated code prior to submission and paste it into a separate SAS code node 
in EG to edit and run later.

AUTOMATICALLY SAVING LOGS TO DISK
By default, EG stores Logs inside the project file, and not to disk.  However, it is possible to add an Export node to 
automatically save the Log to disk, either to a locally referenced folder using the Local Server, or to a folder connected to 
the Remote Server.

To create an Export node for a Log you must have already run the code and generated a Log:

1. Open the Project Explorer.
2. Find the Log you wish to Export and right-click it.
3. Click menu option Export > Export Log As A Step In Project...
4. Click Next >.
5. Select Log File (*.log) in the list and click Next >.
6. Click SAS Servers radio button and then click Edit...
7. Double-click the appropriate server from the list and find the correct folder, edit the filename and then click 

Save.
8. Click Next >.
9. Click Finish.
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CONTACT INFORMATION
The author is a consultant for Holland Numerics Ltd and can be contacted at the following address:

Philip R Holland
address: Holland Numerics Ltd

94 Green Drift
Royston
Herts. SG8 5BT
UK

e-mail: phil@hollandnumerics.com
web: www.hollandnumerics.com
tel. (mobile): +44-(0)7714-279085

This paper and associated sample SAS code can be downloaded from the Holland Numerics Ltd web site at:
www.hollandnumerics.com/SASPAPER.HTM

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute 
Inc. in the USA and other countries. ® indicates USA registration.
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